Back to overview
Downtime

Koin Cafe group @ Game renovation alert!

Jul 23 at 11:42pm PDT
Affected services
roblox.com/communities/33502070/Koin-Cafe#!/about
roblox.com/communities/33502070/Koin-Cafe#!/about
roblox.com/communities/33502070/Koin-Cafe#!/about
roblox.com/communities/33502070/Koin-Cafe#!/about
roblox.com/communities/33502070/Koin-Cafe#!/about
roblox.com/communities/33502070/Koin-Cafe#!/about
roblox.com/communities/33502070/Koin-Cafe#!/about
roblox.com/communities/33502070/Koin-Cafe#!/about

Updated
Jul 24 at 08:40am PDT

Undergoing updates has been issued, and a hard speed has been put on the development & ownership team.

Created
Jul 23 at 11:42pm PDT

The game is being transferred and fixing ongoing glitches. Thank you for your patience.